Guide :Boating : Outboard Motor Boat Bass Fishing Saltwater Base

No acceleration I have a 75 horse power evinrude outboard starts and runs great out of the water idles and goes up throttle like a champ on the hose but as soon as I get in the water it falls on its face I have to pump the choke to get it to run good.It will only run good for a couple minutes then it falls again hit the choke and it runs great again for a couple minutes and continues this way.I thought if I ran it a while it would line itself out but it hasn't.any help would be appreciated thanks

Posted by onealjoneal on Feb 28, 2009

Research, Knowledge and Information :


Mercury 5.0 mpi owners manual - focefivoko877.tk


... 20hp outboard ran great first time out second ... get full power at full throttle. Only will go ... up run good across water for while then it like ...
Read More At : focefivoko877.tk...

The best boat forum for answers to hard qustions about boats


My 5.0 mercruiser will run fine on a hose but on water no power and ... throttle unless I pull the choke out half way, ... starts up good and idles great but ...
Read More At : www.fishingandboats.com...

Full text of "Popular Mechanics ~ 1965" - Internet Archive


Search the history of over 298 billion web pages on the Internet.
Read More At : archive.org...

dulimutihanikid182.ml


1898903611 5aa00fb31fa3568c3951fa8. eb43e0451d5f8bb1 >> Magellan 5000d manual <<< 1331004029 154744962
Read More At : dulimutihanikid182.ml...

Loading ...

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.erodstewart.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0084 seconds